您的位置:首页 > 其它

HDUOJ 1004 Let the Balloon Rise(map容器)

2017-08-05 20:56 218 查看


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 125040    Accepted Submission(s): 49360


Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 

 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

 

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

 

Sample Output

red
pink 

#include<bits/stdc++.h>
using namespace std;
int main(){
string a,maxcolor;
int n,max;
map<string, int> mymap;
while(~scanf("%d",&n)&&n!=0)
{
mymap.clear();//删除所有元素
while(n--)
{
cin>>a;
mymap[a]++;
}
map<string, int>::iterator it;
max=0;
for(it=mymap.begin(); it!=mymap.end();it++)
{
if(it->second>max)
{
max=it->second;//second 是int类型的 值
maxcolor=it->first;//first是map中的第一个string类型的元素 键
}
}
cout<<maxcolor<<endl;
}
return 0;
}


#include <stdio.h>
#include <string.h>
int main()
{
int n,i,j,num[1000];
int max=0,t=0;
char color[1000][16];
while(scanf("%d",&n)!=EOF)
{
if(n)
{
num[0]=0;
scanf("%s",color[0]);
for(i=1;i<n;i++)
{
num[i]=0;
scanf("%s",color[i]);
for(j=0;j<i-1;j++)
if(strcmp(color[i],color[j])==0)
num[i]+=1;
}
max=0;
t=0;
for(i=1;i<n;i++)
if(max<num[i])
{
max=num[i];
t=i;
}
printf("%s\n",color[t]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: