您的位置:首页 > 其它

Codeforces Beta Round #87 (Div. 1 Only)A. Party(深搜/树高)

2017-08-05 17:49 399 查看
传送门

Description

A company has n employees numbered from 1 to n. Each employee either has no immediate manager or exactly one immediate manager, who is another employee with a different number. An employee A is said to be the superior of another employee B if at least one of the following is true:

Employee A is the immediate manager of employee B

Employee B has an immediate manager employee C such that employee A is the superior of employee C.

The company will not have a managerial cycle. That is, there will not exist an employee who is the superior of his/her own immediate manager.

Today the company is going to arrange a party. This involves dividing all n employees into several groups: every employee must belong to exactly one group. Furthermore, within any single group, there must not be two employees A and B such that A is the superior of B.

What is the minimum number of groups that must be formed?

Input

The first line contains integer n (1 ≤ n ≤ 2000) — the number of employees.

The next n lines contain the integers pi (1 ≤ pi ≤ n or pi = -1). Every pi denotes the immediate manager for the i-th employee. If pi is -1, that means that the i-th employee does not have an immediate manager.

It is guaranteed, that no employee will be the immediate manager of him/herself (pi ≠ i). Also, there will be no managerial cycles.

Output

Print a single integer denoting the minimum number of groups that will be formed in the party.

Sample Input

5
-1
1
2
1
-1


Sample Output

3


思路

题解:

根据题意只要求出最大的树高即可。

#include<bits/stdc++.h>
using namespace std;
const int maxn =  2005;
vector<int>itv[maxn];
int res = 0;

void dfs(int u,int depth)
{
res = max(res,depth);
for (unsigned i = 0;i < itv[u].size();i++)
{
dfs(itv[u][i],depth + 1);
}
}

int main()
{
int n,p;
scanf("%d",&n);
for (int i = 1;i <= n;i++)
{
scanf("%d",&p);
if (p == -1)	itv[0].push_back(i);
else	itv[p].push_back(i);
}
dfs(0,0);
printf("%d\n",res);
return 0;
}


 

#include<bits/stdc++.h>
using namespace std;
const int maxn = 2005;
vector<int>itv[maxn];
int level[maxn];

int main()
{
int n,p;
scanf("%d",&n);
for (int i = 1;i <= n;i++)
{
scanf("%d",&p);
if (~p)	itv[p].push_back(i);
else	itv[0].push_back(i);
}
queue<int>que;
for (unsigned i = 0;i < itv[0].size();i++)
{
int u = itv[0][i];
que.push(u);
level[u] = 1;
while (!que.empty())
{
u = que.front();
que.pop();
for (unsigned j = 0;j < itv[u].size();j++)
{
int v = itv[u][j];
level[v] = level[u] + 1;
que.push(v);
}
}
}
int res = 1;
for (int i = 1;i <= n;i++)	res = max(res,level[i]);
printf("%d\n",res);
return 0;
}


  

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: