您的位置:首页 > 其它

hdu 3501 欧拉的和(≤N且与N互质的数的和

2017-08-05 16:01 357 查看
传送门


Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4527    Accepted Submission(s): 1869


Problem Description

Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.

 

Input

For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.

 

Output

For each test case, you should print the sum module 1000000007 in a line.

 

Sample Input

3
4
0

 

Sample Output

0
2

 

Author

GTmac

 

Source

2010 ACM-ICPC Multi-University Training
Contest(7)——Host by HIT

 

Recommend

zhouzeyong

直观想法: 所有小于n且与n为非互质数和=所有小于n数的和-所有小于n且与n互质的数的和

 
原理:

 求所有小于N且与N为互质数的和:

        1.欧拉函数可求与N互质的数的个数

2.if gcd(n,i)=1 then gcd(n,n-i)=1 (1<=i<=n)
若已知m与n互质,则n-m也与n互质
 

那么,对于任何一个i与n互质,必然n-i也和n互质,所以PHI(N)必然是偶数(除了2)

所以从1到N与N互质的数的和为PHI(N)*N/2
 
#include <cstdio>
#include <cstdlib>
#include <ctime>
#include <algorithm>
typedef long long ll;
const int s = 10, MAX_F = 70;
const int mod=1e9+7;

int main()
{
ll n;
while (scanf("%lld", &n), n)
{
ll x=n;
if(n==0) break;
ll ans=n;
if(n%2==0)//只搜n/2次,不然可能超一组 (也可能不超)
{
while(n%2==0) n/=2;
ans=ans/2;
}
for(long long i=3; i*i<=n; i+=2)
//每找到一个就更改上界,这个优化很多,所以直接copy刘汝佳的代码会超时
{
if(n%i==0)
{
while(n%i==0) n/=i;
ans=ans/i*(i-1);
}
}
if(n>1) ans=ans/n*(n-1);
ll sum=(x-1)*x/2;
sum%=mod;
sum=sum-(ans*x/2)%mod;
sum=(sum+mod)%mod;
printf("%lld\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: