您的位置:首页 > 其它

HDU 6077 17多校4 Time To Get Up 水题

2017-08-05 10:12 399 查看
[align=left]Problem Description[/align]
Little Q's clock is alarming! It's time to get up now! However, after reading the time on the clock, Little Q lies down and starts sleeping again. Well, he has 5 alarms, and it's just the first one, he can continue sleeping for a while.

Little Q's clock uses a standard 7-segment LCD display for all digits, plus two small segments for the '':'', and shows all times in a 24-hour format. The '':'' segments are on at all times.



Your job is to help Little Q read the time shown on his clock.

[align=left]Input[/align]
The first line of the input contains an integer T(1≤T≤1440), denoting the number of test cases.

In each test case, there is an 7×21 ASCII image of the clock screen.

All digit segments are represented by two characters, and each colon segment is represented by one character. The character ''X'' indicates a segment that is on while ''.'' indicates anything else. See the sample input for details.

[align=left]Output[/align]
For each test case, print a single line containing a string t in the format of HH:MM, where t(00:00≤t≤23:59), denoting the time shown on the clock.

[align=left]Sample Input[/align]

1

.XX...XX.....XX...XX.
X..X....X......X.X..X

X..X....X.X....X.X..X
......XX.....XX...XX.
X..X.X....X....X.X..X

X..X.X.........X.X..X

.XX...XX.....XX...XX.

[align=left]Sample Output[/align]

02:38
题意:把字符串翻译成时间。

题解:直接利用他们的区别判断即可。

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<cmath>
#include<cstring>
using namespace std;

char time[7+1][21+1];
int check(int i)
{
int j;
if(time[6][i]=='X')
{
if(time[4][i+1]=='.')
return 0;
else if(time[2][i]=='.')
return 2;
else if(time[2][i+3]=='.')
return 6;
else
return 8;
}
else
{
if(time[2][i]=='X')
{
if(time[1][i+1]=='X')
{
if(time[2][i+3]=='X')
return 9;
else
return 5;
}
else
return 4;
}
else
{
if(time[4][i+1]=='.')
{
if(time[1][i+1]=='X')
return 7;
else
return 1;
}
else
return 3;
}
}
}

int main()
{
int a,b,c,d;
int T;
scanf("%d",&T);
while(T--)
{
for(int i=1;i<=7;i++)
for(int j=1;j<=21;j++)
cin>>time[i][j];
a=check(1);
b=check(6);
c=check(13);
d=check(18);
printf("%d%d:%d%d\n",a,b,c,d);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: