您的位置:首页 > 产品设计 > UI/UE

CSU-ACM2017暑期训练8-动态规划初步 C - Common Subsequence

2017-08-04 23:22 411 查看

C - Common Subsequence

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.


Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.


Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.


Sample Input

abcfbc         abfcab
programming    contest
abcd           mnp


Sample Output

4
2
0


​ 状态转移方程

f(i,j)={f(i−1,j−1)+1max(f(i−1,j),f(i,j−1)),,a[i]=b[j]a[i]≠b[j]

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <vector>
using namespace std;

int dp[1000][1000];

int main(){
#ifdef TEST
freopen("test.txt", "r", stdin);
#endif // TEST

string str1, str2;
int len1, len2;
while(cin >> str1 >> str2){
len1 = str1.length(), len2 = str2.length();
memset(dp, 0, sizeof(dp));
for(int i = 0; i < len1; i++){
for(int j = 0; j < len2; j++){
if(str1[i] == str2[j])
dp[i+1][j+1] = dp[i][j] + 1;
else
dp[i+1][j+1] = max(dp[i][j+1],dp[i+1][j]);
}
}
cout << dp[len1][len2] << endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  动态规划