您的位置:首页 > 其它

HDU1052:田忌赛马《贪心》

2017-08-04 22:57 267 查看

HDU1052 :田忌赛马《历史贪心问题》

HDU1052

HDU1052

第一个链接是杭电的,第二个是vju的。

Here is a famous story in Chinese history.

“That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.”

“Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.”

“Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian’s. As a result, each time the king takes six hundred silver dollars from Tian.”

“Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.”

“It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king’s regular, and his super beat the king’s plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?”



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian’s horses on one side, and the king’s horses on the other. Whenever one of Tian’s horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching…

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses — a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input

3

92 83 71

95 87 74

2

20 20

20 20

2

20 19

22 18

0

Sample Output

200

0

0

每次输入一个n代表马匹数,下一行输出田忌每一匹马的数值,然后是王的马匹数值。田忌赢一局得200,输一局扣200,求田忌最多能赚多少。

这题首先想到的是贪心,问题是怎么贪呢?假如田忌最好的马比王最好的马好,那就用田忌最好的马和王最好的马比(因为田忌这匹马是稳赢的,当然要打倒最强的对手才能让后面多赢)。如果田忌最好的马比齐王的差,那就用最差的和齐王最好的比。如果田忌和齐王最好的一样强?这时就比较最差的,若是田忌最差的比齐王的差,那就拿去和齐王最好的比;若是比齐王最差的强,那就和齐王最差的比(注意:这时候不应和齐王最强的比,因为这会导致本来可以是一胜一平的变成一胜一负)。嗯,贪心思路就是这样,下面上代码

#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
int tian[1000],king[1000];
int n;
while(cin>>n&&n)
{   if(n==0)
break;
for(int i=0;i<n;i++)
{
cin>>tian[i];
}
for(int i=0;i<n;i++)
{

4000
cin>>king[i];
}
int t1=0,t2=n-1,k1=0,k2=n-1;
//t1、t2分别是田忌最差和最好的马,k1、k2是齐王的。
int sum=0;
sort(tian,tian+n);
sort(king,king+n);
for(int i=0;i<n;i++)
{
//田忌最好的马能赢齐王最好的马
if(tian[t2]>king[k2])
{
sum+=200;t2-=1;k2-=1;
}
//田忌最好的马比不过给齐王最好的马,用田忌最弱的和齐王比
else if(tian[t2]<king[k2])
{
sum-=200;t1+=1;k2-=1;
}
//最好的马一样强
else if(tian[t2]==king[k2]&&tian[t1]<king[k1])
{
sum-=200;t1+=1;k2-=1;
}
else if(tian[t2]==king[k2]&&tian[t1]>king[k1])
{
sum+=200;t1+=1;k1+=1;
}
else if(tian[t2]==king[k2]&&tian[t1]==king[k1])
{
if(tian[t1]<king[k2])sum-=200;
t1+=1;k2-=1;
}
}cout<<sum<<endl;
}
return 0;
}


最近每两天一次的多校联赛真的是疲惫,题目太难只能过过水题,只有写博客的时候才能找回寒假Accepted的快感。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 贪心算法