您的位置:首页 > 其它

POJ 2739 Sum of Consecutive Prime Numbers

2017-08-04 21:14 351 查看
Sum of Consecutive Prime Numbers

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 25972 Accepted: 14099
Description

Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has
three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 

numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 

Your mission is to write a program that reports the number of representations for the given positive integer.
Input

The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.
Output

The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted
in the output.
Sample Input
2
3
17
41
20
666
12
53
0

Sample Output
1
1
2
3
0
0
1
2

题目链接:http://poj.org/problem?id=2739
题意:计算一个数可以由多少组连续素数相加得到

解题思路:将素数表事先准备好,因为是由连续素数相加得到,所以采用尺取法沿着素数表移动计算即可。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int prime[10000];
void getPrimeSheet()//得到10000以内的素数表
{
int i,j,k;
int isPrime[10000];
memset(isPrime,0,sizeof(isPrime));
k=0;
for(i=2;i<10000;i++)
{
if(!isPrime[i])
{
prime[k++]=i;
for(j=1;i*j<10000;j++)
{
isPrime[i*j]=1;
}
}
}
}
void solve(int n)
{
int s,t;
int cnt;
int sum;
s=0,t=0;
sum=0,cnt=0;
for(;;)//尺取法
{
while(prime[t]<=n&&sum<n)
{
sum+=
95f4
prime[t++];
}
if(sum==n) cnt++;//可以由连续素数得到,答案加一
sum-=prime[s++];//减去最前面的素数
if(s==t) break;
}
printf("%d\n",cnt);
}
int main(void)
{
int n;
getPrimeSheet();
scanf("%d",&n);
while(n)
{
solve(n);
scanf("%d",&n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: