您的位置:首页 > 其它

POJ 1651:Multiplication Puzzle(区间DP)

2017-08-04 20:58 337 查看

Multiplication Puzzle

Time limit:1000 ms Memory limit:65536 kB

Problem Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.


Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.


Output

Output must contain a single integer - the minimal score.


Sample Input

6
10 1 50 50 20 5


Sample Output

3650


题意:

给出N个元素,第一个和第n个不能选,每次选择第k个,获得点数 a[k]=a[k-1]*a[k]*a[k+1],选到只剩第一个和最后一个为止。求最小点数

解题思路:

在i~j个元素中,设第k个最后选dp[i][j]=min(dp[i][j],dp[i][k−1]+a[i−1]∗a[k]∗a[j+1]+dp[k+1][j]);

Code:

#include <iostream>
#include <cstring>
#include <algorithm>
#include <vector>
#include <cstdio>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=105;
int a[maxn];
int dp[maxn][maxn];

int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=1; i<=n; i++)
scanf("%d",a+i);
mem(dp,0);
for(int len=1;len<n-1;len++)
{
for(int i=2;i<n-len+1;i++)
{
int j=i+len-1;
dp[i][j]=1e9;
for(int k=i;k<=j;k++)
{
dp[i][j]=min(dp[i][j],dp[i][k-1]+a[i-1]*a[k]*a[j+1]+dp[k+1][j]);
}
}
}
printf("%d\n",dp[2][n-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: