您的位置:首页 > 产品设计 > UI/UE

HDU 4027 Can you answer these queries?(线段树求区间和)

2017-08-04 16:02 501 查看


                     Can you answer these queries?

 

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance.
For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants
to evaluate the effect of the weapon, so he asks you for help. 

You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line. 

Notice that the square root operation should be rounded down to integer.

InputThe input contains several test cases, terminated by EOF. 

  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000) 

  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63. 

  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000) 

  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query
of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive. 

OutputFor each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10
1 2 3 4 5 6 7 8 9 10
5
0 1 10
1 1 10
1 1 5
0 5 8
1 4 8


Sample Output
Case #1:
19
7
6


题意:我军的秘密武器对敌军战舰区间性造成伤害,每次都会使一整排的战舰收的伤害,并且每个战舰的防护罩的值会变回原来的平方根,向下取平方根,m的操作行数,第一个0为攻击x-y区间的战舰,第一个为1表示询问x-y区间内的防护罩总值

思路:一开始没有进行优化超时了,当防护罩的值小于等于1时,不用再继续进行平方根了,某个区间都是小于等于1的话,那这个区间也不用再继续平方根了

再利用线段树修改和求和就好了

上代码

#include<iostream>
#include<cmath>
#include<cstring>
#include<cstdio>
#include<string>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
#define ls l,m,rt<<1
#define rs m+1,r,rt<<1|1
#define maxn 100010
ll sum[maxn << 2];
bool visit[maxn << 2];
void pushup(int rt)
{
sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
visit[rt] = visit[rt << 1] && visit[rt << 1 | 1];//如果都不能平方根,势必visit[rt]也不能平方根
}
void build(int l, int r, int rt)
{
if (l == r)
{
scanf("%lld", &sum[rt]);
return;
}
int m = (l + r) >> 1;
build(ls);
build(rs);
pushup(rt);
}
void updata(int L, int R, int l, int r, int rt)
{
if (l == r)
{
sum[rt] = sqrt(sum[rt]);
if (sum[rt] <= 1)//小于等于1已经是不能在平方根了
visit[rt] = true;
return;
}
int m = (l + r) >> 1;
if (m >= L && !visit[rt])
updata(L, R, ls);
if (R>m && !visit[rt])
updata(L, R, rs);
pushup(rt);//向上更新节点
}
ll query(int L, int R, int l, int r, int rt)
{
if (L <= l&&R >= r)
return sum[rt];
int m = (l + r) >> 1;
ll ans = 0;
if (m >= L)
ans += query(L, R, ls);
if (R>m)
ans += query(L, R, rs);
return ans;
}
int main()
{
//freopen("Text.txt","r",stdin);
int n, q, st, nd, t;
int k = 1;
while (scanf("%d", &n) != EOF)
{
memset(visit, false, sizeof(visit));
printf("Case #%d:\n", k++);
build(1, n, 1);
scanf("%d", &q);
while (q--)
{
scanf("%d%d%d", &t, &st, &nd);
if (st>nd)
swap(st, nd);//这是坑,天坑
if (t == 0)
updata(st, nd, 1, n, 1);
else
printf("%lld\n", query(st, nd, 1, n, 1));
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  线段树 区间求和
相关文章推荐