您的位置:首页 > 其它

HDU2602 Bone Collector(01背包模板 一维数组)

2017-08-04 10:29 375 查看
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).

Sample Input

1

5 10

1 2 3 4 5

5 4 3 2 1

Sample Output

14

题意:给出n,W。表示有n个物品,背包容量为W。

接下来一行是每个物品的价值。

下一行对照着是每个物品的体积。

解题思路:直接套用01背包模板。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[1010][1010];//最多1000个物品,背包容积最大为1000

int main()
{
int t,n,W,i,j;
int w[1010],v[1010];
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&W);
for(i=0;i<n;i++)
scanf("%d",&v[i]);//输入价值
for(i=0;i<n;i++)
scanf("%d",&w[i]);//输入体积
//01背包
for(i=0;i<n;i++)
for(j=0;j<=W;j++)//注意范围
{
if(j<w[i]) dp[i+1][j]=dp[i][j];
else dp[i+1][j]=max(dp[i][j],dp[i][j-w[i]]+v[i]);
}
printf("%d\n",dp
[W]);//递推至n,W。得出结果
}
return 0;
}


现补上一维数组解法!节省空间(大大滴…)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[1010];

int main()
{
int t,n,W,i,j;
int w[1010],v[1010];
scanf("%d",&t);
while(t--)
{
memset(dp,0,sizeof(dp));
scanf("%d%d",&n,&W);
for(i=0;i<n;i++)
scanf("%d",&v[i]);
for(i=0;i<n;i++)
scanf("%d",&w[i]);

for(i=0;i<n;i++)
for(j=W;j>=w[i];j--)
{
dp[j]=max(dp[j],dp[j-w[i]]+v[i]);
}

printf("%d\n",dp[W]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: