您的位置:首页 > 其它

ZCMU新人训练赛J

2017-08-04 09:52 162 查看


J - Dream City ZOJ
- 3211 

JAVAMAN is visiting Dream City and he sees a yard of gold coin trees. There are ntrees in the yard. Let's call them tree 1, tree 2 ...and tree n. At the first day, each tree i has ai coins on it (i=1,
2, 3...n). Surprisingly, each tree i can growbi new coins each day if it is not cut down. From the first day, JAVAMAN can choose to cut down one tree each day to get all the coins on it. Since he can stay in the Dream
City for at most m days, he can cut down at most m trees in all and if he decides not to cut one day, he cannot cut any trees later. (In other words, he can only cut down trees for consecutive m or less days from the first day!)

Given n, m, ai and bi (i=1, 2, 3...n), calculate the maximum number of gold coins JAVAMAN can get.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 200) indicates the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains 2 positive integers n and m (0 < m <= n <= 250) separated by a space. The second line of each test case contains n positive integers separated
by a space, indicating ai. (0 < ai <= 100, i=1, 2, 3...n) The third line of each test case also contains npositive integers separated by a space,
indicating bi. (0 < bi <= 100, i=1, 2, 3...n)

<b< dd="">

Output

For each test case, output the result in a single line.

<b< dd="">

Sample Input

2
2 1
10 10
1 1
2 2
8 10
2 3


Sample Output

10
21


Hints:

Test case 1: JAVAMAN just cut tree 1 to get 10 gold coins at the first day.

Test case 2: JAVAMAN cut tree 1 at the first day and tree 2 at the second day to get 8 + 10 + 3 = 21 gold coins in all.

AC代码:

01背包,dp规划

#include<iostream>

#include<cstdio>

#include<string.h>

#include<cstring>

#include<queue>

#include<stdio.h>

#include<vector>

#include<set>

#include<stack>

#include<map>

#include<climits>

#include<algorithm>

using namespace std;

const int N=260;

#define LL long long

struct node

{

        int a,b;

}tree
;

bool cmp(const node a,const node b)

{

        return a.b<b.b;

}

int main()

{

        int t;

        scanf("%d",&t);

        while(t--)

        {

                int n,m;

                scanf("%d%d",&n,&m);

                for(int i=1;i<=n;i++)

                        cin>>tree[i].a;

                for(int i=1;i<=n;i++)

                        cin>>tree[i].b;

                sort(tree+1,tree+1+n,cmp);

                int dp

;

                memset(dp,0,sizeof(dp));

                for(int i=1;i<=n;i++)

                        for(int j=1;j<=m;j++)

                        dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]+tree[i].a+tree[i].b*(j-1));

                printf("%d\n",dp
[m]);

        }

        return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: