您的位置:首页 > 其它

Aggressive cows POJ - 2456 二分 最大值最小化

2017-08-04 09:28 281 查看
Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them
is as large as possible. What is the largest minimum distance?
Input
* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output
* Line 1: One integer: the largest minimum distance

Sample Input
5 3
1
2
8
4
9

Sample Output
3

Hint
OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.

    在位置上放牛,让牛相邻的位置尽可能的大,输出这种情况下最短的距离

    二分搜索距离;;

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int M=100005;
int a[M];
int n,k;
int c(int x)
{
int l=1,t=a[0];
for(int i=0;i<n;i++)
{
if(a[i]-t>=x)
{
l++;
t=a[i];
}
}
if(l>=k)
return 1;
else
return 0;
}
int main()
{
while(~scanf("%d%d",&n,&k))
{
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
int l=0,r=a[n-1];
while(r-l>1)
{
int mid=(l+r)>>1;
if(c(mid))
l=mid;
else
r=mid;
}
printf("%d\n",l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: