您的位置:首页 > 其它

POJ1163 The Triangle

2017-08-04 09:15 375 查看
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5


(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

Sample Output

30

题意:每一个数只能加他脚下的两个数,从第一行到最后一行每一行只能加一个数,找出来和的最大值

解题思路:还是没有能够掌握dp。。从最后一行往前推。每一个数选择脚下两个数中和比较大的那个数。

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[110][110];

int main()
{
int a[110][110];
int n,i,j;
while(~scanf("%d",&n))
{
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&a[i][j]);

for(i=n;i>=1;i--)//从最后一行到第一行
for(j=1;j<=i;j++)//也可写for(j=i;j>=1;j--)
dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+a[i][j];

printf("%d\n",dp[1][1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: