您的位置:首页 > 其它

HDU-2120 Ice_cream's world I

2017-08-03 22:43 447 查看
 Ice_cream's world I

ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

InputIn the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has
a wall(A and B are distinct). Terminate by end of file.
OutputOutput the maximum number of ACMers who will be awarded. 

One answer one line.
Sample Input
8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7


Sample Output
3


题意:判断成环的个数

#include <iostream>
#include <cstdio>
const int MAX=1e6+10;
int father[MAX];
int cout;
void init(int n)//初始化
{
for(int i = 0; i <= n; i++)
{
father[i]=i;
}
}
int find(int x)//查找
{
if(x!=father[x])
{
return father[x]=find(father[x]);
}
return x;
}
int unite(int a,int b) //合并
{
int fa=find(a);
int fb=find(b);
if(fa!=fb)
{
father[fa]=fb;
}
else
cout++;
return cout;
}
int main()
{
int n,m;
while(~scanf("%d %d",&n,&m))
{
init(n);
int a,b;
cout=0;
for(int i = 0;i < m ; i++)
{
scanf(" %d %d",&a,&b);
unite(a,b);
}

printf("%d\n",cout);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: