您的位置:首页 > 产品设计 > UI/UE

2017杭电多校联赛team4 Questionnaire 水

2017-08-03 16:55 435 查看


Questionnaire

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0
Special Judge


Problem Description

In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.



Picture from Wikimedia Commons

Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer ai to
represent his opinion. When finished, the leader will choose a pair of positive interges m(m>1) and k(0≤k<m),
and regard those people whose number is exactly k modulo m as
''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of m and k.

 

Input

The first line of the input contains an integer T(1≤T≤15),
denoting the number of test cases.

In each test case, there is an integer n(3≤n≤100000) in
the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are n distinct
integers a1,a2,...,an(1≤ai≤109),
denoting the number that each person chosen.

 

Output

For each test case, print a single line containing two integers m and k,
if there are multiple solutions, print any of them.

 

Sample Input

1
6
23 3 18 8 13 9

 

Sample Output

5 3

 

题目大意:
要使序列中的每个数%m=k,输出任意一组m、k。

思路: 
可以令m=2,再统计奇偶性即可。

ac代码:
#include<stdio.h>

int main()
{
int t,n,num,j,o;

scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
j=o=0;
for(int i=0;i<n;i++)
{
scanf("%d",&num);
if(num&1) j++;
else o++;
}
if(j>=o) printf("2 1\n");
else printf("2 0\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: