您的位置:首页 > 编程语言 > Go语言

HDU-4722-Good Numbers(找规律)

2017-08-03 15:03 387 查看
Online Judge Online Exercise Online Teaching Online Contests Exercise Author

F.A.Q

Hand In Hand

Online Acmers

Forum | Discuss

Statistical Charts

Problem Archive

Realtime Judge Status

Authors Ranklist

C/C++/Java Exams

ACM Steps

Go to Job

Contest LiveCast

ICPC@China

Best Coder beta

VIP | STD Contests

Virtual Contests

DIY | Web-DIY beta

Recent Contests

Author dzc221

Mail Mail 0(0)

Control Panel Control Panel

Sign Out Sign Out

欢迎参加——2017”百度之星”程序设计大赛

Good Numbers

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5185 Accepted Submission(s): 1638

Problem Description

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.

You are required to count the number of good numbers in the range from A to B, inclusive.

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.

Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).

Output

For test case X, output “Case #X: ” first, then output the number of good numbers in a single line.

Sample Input

2

1 10

1 20

Sample Output

Case #1: 0

Case #2: 1

Hint

The answer maybe very large, we recommend you to use long long instead of int.

#include <stdio.h>
#include <math.h>
#include<stdlib.h>
typedef long long ll;
ll solve(ll a)
{
ll sum=a/10;
ll x=a/10*10;
for(ll i = x; i <= a; i ++)
{
ll num=0;
ll y=i;
while(y)
{
num=(y%10)+num;
y/=10;
}
if(num%10==0)
return sum+1;
}
return sum;
}
int main()
{
int t;
scanf("%d",&t);
for(int k=1; k<=t; k++)
{
ll x,y;
scanf("%lld%lld",&x,&y);
x--;
ll x1,x2;
x1=solve(x);
if(x<0)
x1=0;
x2=solve(y);
ll ans=abs(x2-x1);
printf("Case #%d: %lld\n",k,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: