您的位置:首页 > 其它

poj2395(最小生成树)

2017-08-03 14:16 225 查看
Out of Hay

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17710 Accepted: 6969
Description

The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all
of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she
plans her route between farms such that she minimizes the amount of water she must carry. 

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack
over a road in order to minimize the length of the longest road she'll have to traverse.
Input

* Line 1: Two space-separated integers, N and M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
Output

* Line 1: A single integer that is the length of the longest road required to be traversed.
Sample Input
3 3
1 2 23
2 3 1000
1 3 43

Sample Output
43


水题,见代码:

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define INF 1e9+1
#define MAX_V 2005
int cost[MAX_V][MAX_V];
int mincost[MAX_V];
bool used[MAX_V];
int V,E;
void init()
{
for(int i=0;i<V;i++)
{
for(int j=0;j<V;j++)
{
cost[i][j]=INF;
}
cost[i][i]=0;
}
}
int Fake_prim()
{
int longestroad=0;
for(int i=0;i<V;i++)
{
mincost[i]=INF;
used[i]=false;
}
mincost[0]=0;
// int res=0;

4000
while(true)
{
int v=-1;
for(int u=0;u<V;u++)
if(!used[u]&&(v==-1||mincost[u]<mincost[v]))v=u;
if(v==-1)break;
used[v]=true;
if(mincost[v]>longestroad)longestroad=mincost[v];
// res+=mincost[v];
for(int u=0;u<V;u++)
mincost[u]=min(mincost[u],cost[v][u]);
}
// return res;
return longestroad;
}
int main()
{
cin>>V>>E;
init();
int f,t,c;
for(int i=0;i<E;i++)
{
cin>>f>>t>>c;
if(cost[f-1][t-1]==INF||(cost[f-1][t-1]>c))
{
cost[f-1][t-1]=c;
cost[t-1][f-1]=c;
}
}
cout<<Fake_prim()<<endl;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: