您的位置:首页 > 其它

Genealogical tree POJ - 2367(拓扑模板)

2017-08-03 09:24 405 查看


 Genealogic


al tree


 POJ
- 2367



The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will
be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 

And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than
to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake
first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 

Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input
The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural
numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may
be empty. The list (even if it is empty) ends with 0.

Output





The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least
one such sequence always exists.

Sample Input





5
0
4 5 1 0
1 0
5 3 0
3 0


Sample Output
2 4 5 3 1


代码:

#include<stdio.h>
#include<string.h>
int mp[110][110],is[110],sor[105];
void topo(int n)
{
int i,j,m,u;
for(j=1; j<=n; j++)
{
for(i=1; i<=n; i++)//检查入度为0的点并标记
{
if(is[i]==0)
u=i;
}
sor[j]=u;//将入度为0的顶点记录到数组里,用来输出
is[u]=-1;//将标记过的挑选出来,以免再次输出
for(i=1; i<=n; i++)
{
if(mp[u][i])//将与入度为0的点的入度减1,
is[i]--;
}
}
for(i=1; i<=n; i++)
printf("%d ",sor[i]);
printf("\n");
}
int main()
{
int n,m,i,j;
scanf("%d",&n);
memset(mp,0,sizeof(mp));
for(i=1; i<=n; i++)
{
while(scanf("%d",&m),m)//不确定数组长度用while输入
{
mp[i][m]=1;//记录并标记存在的边
is[m]++;//记录每个点的入度
}
}
topo(n);//拓扑排序
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: