您的位置:首页 > 产品设计 > UI/UE

POJ 3061 Subsequence

2017-08-03 09:06 183 查看
Subsequence

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15819 Accepted: 6675
Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum
of which is greater than or equal to S.
Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The
input will finish with the end of file.
Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output
2
3

题目链接:http://poj.org/problem?id=3061

题意:给定长度为n的整数数列以及整数S,求总和不小于S的连续子序列长度的最小值。如果杰不存在,则输出0。

解题思路:采用尺取法,设以a[s]开始的最初大于S的连续子序列为a[s]+a[s+1]+...+a[t-1],这时a[s+1]+a[s+2]+...+a[t-2]<S,所以从a[s+1]开始总和最初超过S的连续子序列如果是a[s+1]+a[s+2]+...+a[t‘-1]的话,则必然有t<=t'。利用这一性质便可以设计出这样的算法:1、以s=t=sum=0初始化。2、只要依然有sum<S,就不断将sum增加a[t],并将t增1。3、如果2中无法满足sum>=S的条件的话就跳出循环。否则更新ans=min(ans,t-s)。4、将sum减去a[s],s增加1后回到2。(可以参考挑战程序设计竞赛)

AC代码:

4000

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN = 1e5+7;
int n,S;
int a[MAXN];
void solve()
{
int ans=n+1;
int sum=0,s=0,t=0;
for(;;)
{
while(t<n&&sum<S)
{
sum+=a[t++];
}
if(sum<S) break;
ans=min(ans,t-s);
sum-=a[s++];
}
if(ans>n) ans=0;
printf("%d\n",ans);
}
int main(void)
{
int T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&n,&S);
for(int i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: