您的位置:首页 > 其它

1105. Spiral Matrix (25)

2017-08-02 23:48 471 查看
This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.


Input Specification:


Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.


Output Specification:


For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93


Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76


#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int num[10004];
int num2[1000][1000];
bool cmp(int a,int b)
{
return a>b;
}
int main()
{
int t,row,col,i,j,n,flag=0,minn=999999;
cin>>t;
for(i=1;i<=sqrt(t*1.0);i++)
{
if(t%i==0)
{
if(t/i-i<minn)
{
minn=t/i-i;
col=i;
}
}
}
row=t/col;
for (int i=0;i<t;i++)
cin>>num[i];
sort(num,num+t,cmp);
int x=0;
for (n=0;;n++)
{
for (j=n;j<col-n;j++)
{
num2
[j]=num[x++];
if (t==x)
{
flag=1;
break;
}
}
if (flag) break;
for (i=n+1;i<row-n-1;i++)
{
num2[i][j-1]=num[x++];
if (t==x)
{
flag=1;
break;
}
}
if (flag) break;
for (j--;j>=n;j--)
{
num2[i][j]=num[x++];
if (t==x)
{
flag=1;
break;
}
}
if (flag) break;
for (i--;i>n;i--)
{
num2[i][j+1]=num[x++];
if (t==x)
{
flag=1;
break;
}
}
if (flag) break;
}
for (i=0;i<row;i++)
{
for (j=0;j<col;j++)
{
cout<<num2[i][j];
if (j!=col-1)
cout<<" ";
}
if (i!=row-1)
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: