您的位置:首页 > 其它

Spreading the Wealth,UVa 11300

2017-08-02 21:05 246 查看
【题目】

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

【Input】

There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the

village. n lines follow, giving the number of coins of each person in the village, in counterclockwise

order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

【Output】

For each input, output the minimum number of coins that must be transferred on a single line.

【Sample Input】

3

100

100

100

4

1

2

5

4

【Sample Output】

0

4

【题解】

这是一道推导求中位数的题,看过书上的推导之后一直很迷,觉得递推C数组的式子不对,思考之后发现我沉迷在书上枯燥的推导式中,失去了题的原意,浪费了很长时间。

#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 1000000 + 10;
long long A[maxn], C[maxn], tot, M;

int main() {
int n;
while (scanf("%d", &n) == 1) {
tot = 0;
for (int i = 1; i <= n; i++) {
scanf("%lld", &A[i]);            //用%lld输入long long
tot += A[i];
}
M = tot / n;
C[0] = 0;
for (int i = 1; i < n; i++)
C[i] = C[i - 1] + A[i-1] - M;               //递推C数组
sort(C, C + n);
long long x1 = C[n / 2], ans = 0;        //计算x1
for (int i = 0; i < n; i++)
ans += abs(x1 - C[i]);           //把x1代入,计算转手的总金币数
printf("%lld\n", ans);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: