您的位置:首页 > 其它

POJ 1163 The Triangle (DP)

2017-08-02 20:52 423 查看
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)


Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100.
The numbers in the triangle, all integers, are between 0 and 99.

Output
Your program is to write to standard output. The highest sum is written as an integer.

Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5


Sample Output
30


 【题解】 简单的DP题,从塔顶往下走,每次只能走到当前点的左子节点或右子节点,求从塔顶到塔底的最大值。

  动规的思想,从塔底往回推,相邻两个数取最大的加到上一行的数上,依次类推,转移方程:dp[i][j] = max ( dp [i+1] [j],  dp [i+1] [j+1]);

  【AC代码】

 #include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int main()
{
std::ios::sync_with_stdio(false);
int m,n,dp[105][105];
cin>>m;
for(int i=1;i<=m;++i)
{
for(int j=1;j<=i;++j)
cin>>dp[i][j];
}
for(int i=m-1;i>0;--i)//注意从倒数第二行开始
{
for(int j=1;j<=i;++j)
{
dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1]);
}
}
printf("%d\n",dp[1][1]);//最顶的值就是最大值
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: