您的位置:首页 > 其它

HDU 6033 Add More Zero

2017-08-02 20:47 766 查看

Add More Zero

[align=left]Problem Description[/align]
There is a youngster known for amateur propositions concerning several mathematical hard problems.

Nowadays, he is preparing a thought-provoking problem on a specific type of supercomputer which has ability to support calculations of integers between
0
and (2m−1)
(inclusive).

As a young man born with ten fingers, he loves the powers of
10
so much, which results in his eccentricity that he always ranges integers he would like to use from
1
to 10k
(inclusive).

For the sake of processing, all integers he wo
bb38
uld use possibly in this interesting problem ought to be as computable as this supercomputer could.

Given the positive integer m,
your task is to determine maximum possible integer
k
that is suitable for the specific supercomputer.
 

[align=left]Input[/align]
The input contains multiple test cases. Each test case in one line contains only one positive integer
m,
satisfying 1≤m≤105.
 

[align=left]Output[/align]
For each test case, output "Case #x:
y"
in one line (without quotes), where x
indicates the case number starting from 1
and y
denotes the answer of corresponding case.
 

[align=left]Sample Input[/align]

1
64

 

[align=left]Sample Output[/align]

Case #1: 0
Case #2: 19

 

[align=left]这道题大概就是2的m次方用科学计数法来表示的话,后面乘的10的幂是多少。[/align]
[align=left]化简一下可以得到结果为n/(log(10)/log(2))。[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]AC代码:[/align]
[align=left]
[/align]
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
using namespace std;
int main()
{
int n;
int res;
int cas=0;
while(cin>>n)
{
cas++;
res= n/(log(10)/log(2));
printf("Case #%d: %d\n",cas,res);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: