您的位置:首页 > 其它

G - Ice_cream's world I 【hdu 2120 并查集】

2017-08-02 19:31 197 查看
题目链接

Ice_cream's world I

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1746    Accepted Submission(s): 1016


[align=left]Problem Description[/align]
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition
the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

[align=left]Input[/align]
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between
A and B has a wall(A and B are distinct). Terminate by end of file.
 

[align=left]Output[/align]
Output the maximum number of ACMers who will be awarded.

One answer one line.
 

[align=left]Sample Input[/align]

8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

 

[align=left]Sample Output[/align]

3

题解:问墙最多能围城几组地,实质是求有几个环

AC代码

#include<cstdio>
int pre[10010],n,m,cnt;
void reset()
{
for(int i=0;i<10010;i++)
pre[i]=i;
}
int find(int x)
{
return pre[x]==x?x:find(pre[x]);
}
void join(int a,int b)
{
int le1=find(a);
int le2=find(b);
if(le1!=le2)
pre[le2]=le1;
else
cnt++;
}
int main()
{
while(~scanf("%d%d",&n,&m)){
reset();
int c,d;
cnt=0;
for(int i=0;i<m;i++)
{
scanf("%d%d",&c,&d);
join(c,d);
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: