您的位置:首页 > 其它

D - How Many Tables 【hdu 1213 并查集】

2017-08-02 11:04 393 查看
题目链接

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32484    Accepted Submission(s): 16206


[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

入门题目 ,与 畅通工程有点像。。。。

#include<cstdio>
int pre[1010];
int find(int a)//find函数查找他的领导
{
int leader=a;
while(pre[leader]!=leader)//领导不是自己,找自己的上一级领导
leader=pre[leader];
int t,b=a;
while(b!=leader)
{
t=pre[a];
pre[a]=leader;
b=t;
}
return leader;
}
int main()
{
int t,n,m,point1,point2,all,lead1,lead2;//point表示城镇编号
while(~scanf("%d",&t))
{
while(t--){
scanf("%d%d",&n,&m);
all=n;//n个人需要n个桌子
for(int i=1;i<=n;i++){
pre[i]=i;//初始化为自己的领导是自己
}
for(int j=0;j<m;j++){
scanf("%d%d",&point1,&point2);
lead1=find(point1);
lead2=find(point2);
if(lead1!=lead2){
pre[lead2]=lead1;
all--;//根据题目给出的条件每认识一个人总数减一
}
}
printf("%d\n",all);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: