您的位置:首页 > 其它

poj 2769 Reduced ID Numbers (同余定理)

2017-08-02 08:34 288 查看
Reduced ID Numbers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10341 Accepted: 4114
Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification
within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.
Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain
one SIN. The SINs within a group are distinct, though not necessarily sorted.
Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.
Sample Input
2
1
124866
3
124866
111111
987651

Sample Output
1
8

Source

Northwestern Europe 2005

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int f[305];
int vis[100001];
int main()
{
int T;
int n;
int i,j;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
for( i=0;i<n;i++)
scanf("%d",&f[i]);
for( i=n;;i++)
{
memset(vis,0,sizeof(vis));
for( j=0;j<n;j++)
{
if(vis[f[j]%i])
{
//find=0;
break;
}

4000
vis[f[j]%i]=1;
}
if(j>=n)break;
}
printf("%d\n",i);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: