您的位置:首页 > Web前端

POJ 1990 MooFest (树状数组)

2017-08-02 08:23 387 查看
MooFest

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8063 Accepted: 3640
Description

Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the
cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they
must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. 

Output

* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. 

Sample Input
4
3 1
2 5
2 6
4 3


Sample Output
57


题意:  给n 头牛,  每头牛站成一排, 每个牛都有一个 听力值,  现在 如果两头牛想要相互说话, 则 必须满足  听力值达到 max(v[i],v[j])才可以;

问使得梅梅都可以相互交流 最少的花费是多少;

思路: 使用树状数组 使查询控制在n*log(n) 内  建立两个 树状数组,    分别是距离和 听力值的;  按照 听力值上升排序,  这样 每次 的都是最大的;

要查询 当前为值  左边的 距离比他小的个数, 和右边比他的个数;  

则 左边就是 x*a-b    右边是 b-a*x;  要用long long  数据大

#include <iostream>
#include <stdio.h>
#include <cmath>
#include <queue>
#include <cstring>
#include <algorithm>

typedef long long ll;

using namespace std;
const int N =20019;
ll tree_n
;
ll tree_x
;
ll n;
struct node{
ll v, x;
}a
;
int cmp(node a,node b)
{
return a.v<b.v;
}
void add(ll tree[],int k,ll num)//维护添加值
{
while(k<=N)
{
tree[k]+=num;
k+=k&(-k);// lowbit(k)= k&(-k);
}
}
ll Sum(int x,ll tree[])//求区间[1,x] 的和
{
ll sum=0;
while(x>0)
{
sum+=tree[x];
x-=x&(-x);
}
return sum;
}
ll Get_sum(ll tree[],int x,int y)// x-y区间的和
{
return Sum(y-1,tree)-Sum(x-1,tree);
}

int main()
{
// freopen("input.txt","r",stdin);

while(cin>>n)
{
memset(tree_n,0,sizeof(tree_n));
memset(tree_x,0,sizeof(tree_x));
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
scanf("%lld %lld",&a[i].v,&a[i].x);
sort(a+1,a+n+1,cmp);
ll ans=0;
for(int i=1;i<=n;i++)
{
ll left=a[i].x*Sum(a[i].x-1,tree_n)-Sum(a[i].x-1,tree_x);
ll right=Get_sum(tree_x,a[i].x,N)-a[i].x*Get_sum(tree_n,a[i].x,N
c6ad
);
ans+= (left+right) * a[i].v;
add(tree_n,a[i].x,1);// v值
add(tree_x,a[i].x,a[i].x);// 距离
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: