您的位置:首页 > 其它

RXD and math(HDU 6063 快速幂)

2017-08-01 21:09 302 查看


RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 293    Accepted Submission(s): 150

Problem Description

RXD is a good mathematician.

One day he wants to calculate:

∑i=1nkμ2(i)×⌊nki−−−√⌋

output the answer module 109+7.
1≤n,k≤1018

μ(n)=1(n=1)

μ(n)=(−1)k(n=p1p2…pk)

μ(n)=0(otherwise)

p1,p2,p3…pk are
different prime numbers

 

Input

There are several test cases, please keep reading until EOF.

There are exact 10000 cases.

For each test case, there are 2 numbers n,k.

 

Output

For each test case, output "Case #x: y", which means the test case number and the answer.

 

Sample Input

10 10

 

Sample Output

Case #1: 999999937

 //题意:已知n,k,求表达式的值。

//思路:那个μ(n)是莫比乌斯函数,p代表的是质数,具体了解自行百度。

这题属于找规律,算几个就能发现规律:

n^k=2:所求值=2;
n^k=3:所求值=3;
n^k=4:所求值=4;
n^k=5:所求值=5;
......
n^k:所求值n^k;

这题就是求(n^k)%(1e9+7),套个快速幂即可。不过快速幂里有个细节要注意,代码里已标注。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
using namespace std;

typedef long long ll;

const ll MOD = 1e9 + 7;

ll n, k;

ll multiply(ll a, ll b)
{
ll ans = 1;
while (b)
{
if (b & 1)
{
ans = ((ans%MOD)*(a%MOD)) % MOD;
b--;
}
b /= 2;
//注意这里a要先%MOD,不然第一次a*a会超过long long,会WA!!!
a = ((a%MOD)*(a%MOD)) % MOD;
}
return ans;
}

int main()
{
int Case = 1;
while (scanf("%lld%lld", &n, &k) != EOF)
{
ll sum = multiply(n, k);
printf("Case #%d: %lld\n", Case++, sum%MOD);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: