您的位置:首页 > 其它

Poj 1383--Labyrinth【树的直径】【bfs】

2017-08-01 19:59 323 查看
题目地址:http://poj.org/problem?id=1383

Labyrinth

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 4708 Accepted: 1763
Description

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have
found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means
also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow,
each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks
are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 

The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output

Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######

Sample Output
Maximum rope length is 0.
Maximum rope length is 8.

Hint

Huge input, scanf is recommended. 

If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc
Source

Central Europe 1999

题意:给你一个N*M的图,迷宫里面有' # '和 ' . ' 两种字符,问你距离最远的两个' . '之间的距离。

解题思路:首先找到任意一个' . '的坐标(x1, y1),然后以该坐标为起点BFS整个迷宫找最长路,找到该坐标对应最长路的终点(x2, y2)。再以(x2, y2)为起点BFS整个迷宫找最长路即可。即两次bfs

#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
struct node
{
int x,y,step;
}pr,ne;
int vis[1050][1050];
char mapp[1050][1050];
int w,h,i,j,nx,ny,sum,x1,x2,y1,y2;
int fx[4]={0,0,1,-1};
int fy[4]={1,-1,0,0};
bool check(node x)
{
if(x.x >=0&&x.y >=0&&x.x <h&&x.y <w&&!vis[x.x ][x.y ]&&mapp[x.x][x.y ]=='.')
return true;
return false;
}
void bfs(int x,int y)
{

queue<node> q;
memset(vis,0,sizeof(vis));
vis[x][y]=1;
pr.x =x;
pr.y =y;
pr.step =0;
sum=0;
q.push(pr);

while(!q.empty() )
{
pr=q.front() ;
q.pop() ;
for(i=0;i<4;i++)
{
ne.x =pr.x +fx[i];
ne.y =pr.y +fy[i];
if(check(ne))
{
ne.step =pr.step +1;
//				if(!vis[pr.x][pr.y])//bug
//				{
if(sum<ne.step )
{
x2=ne.x ;
y2=ne.y ;
sum=ne.step ;
}
vis[ne.x ][ne.y]=1;
q.push(ne);
//				}
}
}
}
}
int main ()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&w,&h);
for(i=0;i<h;i++)
scanf("%s",mapp[i]);
for(i=0;i<h;i++)
{
for(j=0;j<w;j++)
if(mapp[i][j]=='.')
{
x1=i,y1=j;
break;
}
}
//		sum=0;
bfs(x1,y1);
bfs(x2,y2);
printf("Maximum rope length is %d.\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: