您的位置:首页 > 其它

HDU 2017 多校联赛3 1008 RXD and math

2017-08-01 19:46 471 查看


Problem Description

RXD is a good mathematician. 

One day he wants to calculate:



output the answer module 109+7. 

1≤n,k≤1018 



p1,p2,p3…pk are different prime numbers


Input

There are several test cases, please keep reading until EOF. 

There are exact 10000 cases. 

For each test case, there are 2 numbers n,k.


Output

For each test case, output “Case #x: y”, which means the test case number and the answer.


Sample Input

10 10


Sample Output

Case #1: 999999937


题目大意:




C++

#include<bits/stdc++.h>
#define mod 1000000007
using namespace std;
long long pow(long long a,long long b)
{
long long int ans = 1,base = a;
while(b!=0)
{
if(b&1){
base%=(long long)mod;
ans%=(long long)mod;
ans *= base;
ans%=(long long)mod;
}
base%=(long long)mod;
base *= base;
base%=(long long)mod;
b>>=1;
}
return ans;
}
int main()
{
long long int n,k;
int t=0;
while(~scanf("%lld %lld",&
4000
n,&k)){
t++;
printf("Case #%d: ",t);
printf("%lld\n",pow(n,k));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: