您的位置:首页 > 其它

HDU6060-RXD and dividing

2017-08-01 17:48 337 查看

RXD and dividing

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)

Total Submission(s): 65 Accepted Submission(s): 15

Problem Description

RXD has a tree T, with the size of n. Each edge has a cost.

Define f(S) as the the cost of the minimal Steiner Tree of the set S on tree T.

he wants to divide 2,3,4,5,6,…n into k parts S1,S2,S3,…Sk,

where ⋃Si={2,3,…,n} and for all different i,j , we can conclude that Si⋂Sj=∅.

Then he calulates res=∑ki=1f({1}⋃Si).

He wants to maximize the res.

1≤k≤n≤106

the cost of each edge∈[1,105]

Si might be empty.

f(S) means that you need to choose a couple of edges on the tree to make all the points in S connected, and you need to minimize the sum of the cost of these edges. f(S) is equal to the minimal cost

Input

There are several test cases, please keep reading until EOF.

For each test case, the first line consists of 2 integer n,k, which means the number of the tree nodes , and k means the number of parts.

The next n−1 lines consists of 2 integers, a,b,c, means a tree edge (a,b) with cost c.

It is guaranteed that the edges would form a tree.

There are 4 big test cases and 50 small test cases.

small test case means n≤100.

Output

For each test case, output an integer, which means the answer.

Sample Input

5 4

1 2 3

2 3 4

2 4 5

2 5 6

Sample Output

27

Source

2017 Multi-University Training Contest - Team 3

题目大意:给出一棵树,最大化k个斯坦纳树。

解题思路:将2~n的结点编号{1~k},每条边的权乘以其下子树的大小与k的较小值。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF=0x3f3f3f3f;
const LL MOD=1e9+7;
const int MAXN=1e6+7;
int head[MAXN],tot;
int sz[MAXN],f[MAXN],weight[MAXN];

struct Edge
{
int from,to,cost,nxt;
}e[MAXN*2];

void addedge(int u,int v,int w)
{
e[tot].from=u;
e[tot].to=v;
e[tot].cost=w;
e[tot].nxt=head[u];
head[u]=tot++;
}

void dfs(int u,int fa)
{
sz[u]=1;
for(int i=head[u];i!=-1;i=e[i].nxt)
{
int to=e[i].to;
if(to==fa)  continue;
f[to]=u;
weight[to]=e[i].cost;
dfs(to,u);
sz[u]+=sz[to];
}
}

int main()
{
int n,k;
while(scanf("%d%d",&n,&k)!=EOF)
{
memset(sz,0,sizeof(sz));
memset(head,-1,sizeof(head));
tot=0;
int u,v,w;
for(int i=1;i<=n-1;++i)
{
scanf("%d%d%d",&u,&v,&w);
addedge(u,v,w);
addedge(v,u,w);
}
dfs(1,-1);
LL ans=0;
for(int i=2;i<=n;i++)
{
ans+=(LL)weight[i]*min(sz[i],k);
}
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: