您的位置:首页 > 其它

POJ 2955-Brackets(区间DP)

2017-08-01 15:45 253 查看
题目链接:
http://poj.org/problem?id=2955
Brackets

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8457 Accepted: 4505
Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence
For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]


while the following character sequences are not:

(, ], )(, ([)], ([(]


Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such
that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is
a regular brackets sequence.

Given the initial sequence 
([([]])]
, the longest regular brackets subsequence is 
[([])]
.

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters 
(
)
[
, and 
]
; each input test will have length between 1 and 100, inclusive.
The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input
((()))
()()()
([]])
)[)(
([][][)
end

Sample Output
6
6
4
0
6


//跟括号匹配完全一样,只是结果是输出已经匹配的数目
//用区间dp求出最少需要多少个字符才能使所有括号完全匹配
//结果就是输出的字符串长度减去dp[0][l-1]

//括号匹配:请移步到:http://blog.csdn.net/qq_31281327/article/details/75285872

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 1005
#define inf 0x3f3f3f3f
using namespace std;

int dp[maxn][maxn];
char s[maxn];

int uni(char c1, char c2)
{
if((c1=='(' && c2 == ')') || (c1=='[' && c2==']'))
return 1;
return 0;
}
int main()
{
while(~scanf("%s", s))
{
if(strcmp(s,"end")==0)
break;
int l = strlen(s);
for(int i=0; i<l; i++)
dp[i][i] = 1;

for(int len = 1; len<l; len++)
{
for(int i = 0; i<l-len; i++)
{
int j = i+len;
dp[i][j] = inf;
if(uni(s[i], s[j]))
{
dp[i][j] = min(dp[i+1][j-1], dp[i][j]);
}
for(int k=i; k<j; k++)
{
dp[i][j] = min(dp[i][j], dp[i][k]+dp[k+1][j]);
}
}
}
printf("%d\n", l-dp[0][l-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM 动态规划