您的位置:首页 > 其它

How Many Equations Can You Find

2017-08-01 14:58 417 查看
点击打开链接

Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer
N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

InputEach case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.
OutputThe output contains one line for each data set : the number of ways you can find to make the equation.
Sample Input
123456789 3
21 1


Sample Output
18
1

算法:

#include <cstdio>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <cstring>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x3f3f3f3f
#define LL long long
char s[20];
LL n;
int l;
int ans;
void dfs(LL sum,LL num,int pos,int op) //当前和,已积累数字,位置,积累数字正负
{
if (pos == l) //递归终止条件
{
if (n == sum + num * op)
ans++;
return;
}
dfs(sum,num*10+s[pos]-'0',pos+1,op); //无符号
dfs(sum+num*op,s[pos]-'0',pos+1,1); //加号
dfs(sum+num*op,s[pos]-'0',pos+1,-1); //减号
}
int main()
{
while (~scanf ("%s %lld",s,&n))
{
ans = 0;
l = strlen(s);
dfs(0,s[0]-'0',1,1);
printf ("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: