您的位置:首页 > 其它

HDU 1312 Red and Black <BFS>

2017-08-01 14:11 381 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2364    Accepted Submission(s): 1551


[align=left]Problem Description[/align]
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move
only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

 

[align=left]Input[/align]
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

 

[align=left]Output[/align]
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

 

[align=left]Sample Input[/align]

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

[align=left]Sample Output[/align]
45
59
6
13

又是一道可以用BFS和DFS 的题,这里写的是BFS求解,套模板就好了,只不过不要忽略题目说的一句话,答案是包括起点的,所以定义的结果初始设为1,设为0的时候如果全局就只有一个黑色起点,BFS扩展不下去,结果输出了0,但是除了这种情况其他的情况都能得到正确答案,在这个地方WA了很多次,所以一定要看清楚题目

#include <iostream>
#include <cstring>
#include <stack>
#include <cstdio>
#include <cmath>
#include <queue>
#include <algorithm>
#include <vector>
#include <set>
#include <map>

const double eps=1e-8;
const double PI=acos(-1.0);
using namespace std;

struct Node{
int x,y;
}node;

int n,m;
char a[50][50];
int c[][2]={{0,1},{1,0},{0,-1},{-1,0}};

void bfs(int i,int j){
int ans=1;//初值设为1
queue<Node> q;
node.x=i;
node.y=j;
a[i][j]='#';
q.push(node);
while(!q.empty()){
Node temp,tp=q.front();
q.pop();
for(int k=0;k<4;k++){
temp.x=tp.x+c[k][0];
temp.y=tp.y+c[k][1];
if(temp.x<m&&temp.y<n&&temp.x>=0&&temp.y>=0&&a[temp.x][temp.y]!='#'){
ans++;
q.push(temp);
a[temp.x][temp.y]='#';
}
}

}
printf("%d\n",ans);
}

int main()
{
while(~scanf("%d%d",&n,&m)&&(n||m))
{
int p1,p2;
for(int i=0; i<m; i++)
{
scanf("%s",a[i]);
}
for(int i=0;i<m;i++)
for(int j=0; j<n; j++)
{

if(a[i][j]=='@'){
p1=i,p2=j;
break;
}
}
bfs(p1,p2);
// printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM OJ hdu