您的位置:首页 > 产品设计 > UI/UE

Team Queue UVA - 540 (stl queue使用)

2017-08-01 12:30 561 查看
Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the

queue in front of the Mensa is a team queue, for example.

In a team queue each element belongs to a team. If an element enters the queue, it first searches

the queue from head to tail to check if some of its teammates (elements of the same team) are already

in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail

and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are

processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.

Input

The input file will contain one or more test cases. Each test case begins with the number of teams

t (1 ≤ t ≤ 1000). Then t team descriptions follow, each one consisting of the number of elements

belonging to the team and the elements themselves. Elements are integers in the range 0..999999. A

team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

• ENQUEUE x — enter element x into the team queue

• DEQUEUE — process the first element and remove it from the queue

• STOP — end of test case

The input will be terminated by a value of 0 for t.

Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation

of the team queue should be efficient: both enqueing and dequeuing of an element should

only take constant time.

Output

For each test case, first print a line saying ‘Scenario #k’, where k is the number of the test case. Then,

for each ‘DEQUEUE’ command, print the element which is dequeued on a single line. Print a blank line

after each test case, even after the last one.

Sample Input

2

3 101 102 103

3 201 202 203

ENQUEUE 101

ENQUEUE 201

ENQUEUE 102

ENQUEUE 202

ENQUEUE 103

ENQUEUE 203

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

2

5 259001 259002 259003 259004 259005

6 260001 260002 260003 260004 260005 260006

ENQUEUE 259001

ENQUEUE 260001

ENQUEUE 259002

ENQUEUE 259003

ENQUEUE 259004

ENQUEUE 259005

DEQUEUE

DEQUEUE

ENQUEUE 260002

ENQUEUE 260003

DEQUEUE

DEQUEUE

DEQUEUE

DEQUEUE

STOP

0

Sample Output

Scenario #1

101

102

103

201

202

203

Scenario #2

259001

259002

259003

259004

259005

260001

题目大意:

有t个团队的人正在排一个长队。每次新来一个人时,如果他有队友在排队,那么这个新人会插队到最后一个队友的身后。如果没有任何一个队友排队,则他会排到长队的队尾。

输入每个团队中所有队员的编号,要求支持如下3种指令(前两种指令可以穿插进行)。

ENQUEUE x:编号为x的人进入长队。

DEQUEUE:长队的队首出队。

STOP:停止模拟.

对于每个DEQUEUE指令,输出出队的人的编号。

解题思路:开一个团队的队列,存放团队编号,再开一个队列数组放n个团队的入队情况。

ac代码:

#include<bits/stdc++.h>
using namespace std;
map<int,int>num;
queue<int>xwd,que[1005];
int main()
{
int n;
int case1=0;
while(~scanf("%d",&n)&&n)
{
while(!xwd.empty())
xwd.pop();
for(int i=1;i<=n;i++){
while(!que[i].empty())
que[i].pop();}
int a,c;
for(int i=1;i<=n;i++)
{
scanf("%d",&a);
for(int j=1;j<=a;j++)
{
scanf("%d",&c);
num[c]=i;
}
}
string s;
printf("Scenario #%d\n",++case1);
while(cin>>s)
{
if(s[0]=='E')
{
scanf("%d",&a);
if(!que[num[a]].empty())
{
que[num[a]].push(a);
}
else
{
xwd.push(num[a]);
que[num[a]].push(a);
}
}
else if(s[0]=='D')
{
int team=xwd.front();
if(que[team].size()-1==0)xwd.pop();
int jack=que[team].front();
cout<<jack<<endl;
que[team].pop();
}
else if(s[0]=='S')
{cout<<endl;
break;
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  stl