您的位置:首页 > 其它

[POJ 1269]Intersecting Lines

2017-08-01 11:31 246 查看

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two
lines in the x-y plane and determine how and where the lines intersect.
All numbers required by this problem will be reasonable, say between
-1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目大意

给定n组数据,每组2条直线,求直线关系,关系有如下:1.重合,2.平行,3.相交于一点。

题解

Point1.判断平行和重合:两向量的叉积为$0$;

  Sub1.判断重合,取某一向量上的一点,与另一条向量的一点组成新向量。把该条新向量与任意一条向量叉积,为$0$则重合;

  Sub1.判断平行,取某一向量上的一点,与另一条向量的一点组成新向量。把该条新向量与任意一条向量叉积,不为$0$则平行;

Point2.求交点;

  Sub1.若一条直线斜率不存在,交点横坐标肯定是这条直线在$x$轴上的截距。我们有另一条直线两点式:

,我们将横坐标$x_0$代入,求出纵坐标$y_0$。

  Sub2.斜率均存在,如图:

,即求$P$。

不理解的详请:定比分点

  或者直接令$tmp={S_{ΔABD}\over {S_{ΔABD}+S_{ΔABC}}}$;

  则$x_P=(x_C-x_D)×tmp+x_D$,$y_P=(y_C-y_D)×tmp+y_D$;证明同理。

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<queue>
#include<stack>
#include<cstdio>
#include<string>
#include<vector>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#define LL long long
#define RE register
#define IL inline
using namespace std;
const int N=500;

struct Point
{
double x,y;
Point (){}
Point (double _x,double _y){x=_x;y=_y;}
Point operator - (const Point &b)
const{
return Point(x-b.x,y-b.y);
}
double operator * (const Point &b)
const{
return x*b.y-y*b.x;
}
}a,b,c,d;
int n;

int main()
{
scanf("%d",&n);
printf("INTERSECTING LINES OUTPUT\n");
while (n--)
{
scanf("%lf%lf%lf%lf%lf%lf%lf%lf",
&a.x,&a.y,&b.x,&b.y,&c.x,&c.y,&d.x,&d.y);
if ((a-b)*(c-d)==0)
{
if ((a-b)*(c-b)==0) printf("LINE\n");
else printf("NONE\n");
continue;
}
printf("POINT ");
if (a.x==b.x) printf("%.2lf %.2lf\n",a.x,(a.x-c.x)*(d.y-c.y)/(d.x-c.x)+c.y);
else if (c.x==d.x) printf("%.2lf %.2lf\n",c.x,(c.x-a.x)*(b.y-a.y)/(b.x-a.x)+a.y);
else
{
double tmp=(d-a)*(b-a);
tmp=tmp/(tmp+(b-a)*(c-a));
printf("%.2lf %.2lf\n",(c.x-d.x)*tmp+d.x,(c.y-d.y)*tmp+d.y);
}
}
printf("END OF OUTPUT\n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: