您的位置:首页 > 其它

HDU-1222-Wolf and Rabbit

2017-08-01 10:40 302 查看
点击打开链接


Wolf and Rabbit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8896    Accepted Submission(s): 4520


Problem Description

There is a hill with n holes around. The holes are signed from 0 to n-1.



A rabbit must hide in one of the holes. A wolf searches the rabbit in anticlockwise order. The first hole he get into is the one signed with 0. Then he will get into the hole every m holes. For example, m=2 and n=6, the wolf will get into the holes which are
signed 0,2,4,0. If the rabbit hides in the hole which signed 1,3 or 5, she will survive. So we call these holes the safe holes.

 

Input

The input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).

 

Output

For each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.

 

Sample Input

2
1 2
2 2

 

Sample Output

NO
YES

题解:如果洞的个数和狼跳的个数最大个因数为1,说明狼能把每个洞都跳一遍,如果不是1,那么将有安全的洞

#include<stdio.h>
int main()
{
int n,m,k,s;
scanf("%d",&s);
while(s--)
{
scanf("%d%d",&m,&n);
while(n!=0) //迭代找最大公因数
{
k=m%n;
m=n;
n=k;
}
if(m!=1)
printf("YES\n");
else
printf("NO\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: