您的位置:首页 > 其它

poj 2955 Brackets(区间DP)

2017-08-01 08:54 267 查看

Brackets

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,

if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and

if a and b are regular brackets sequences, then ab is a regular brackets sequence.

no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))

()()()

([]])

)[)(

([][][)

end

Sample Output

6

6

4

0

6

思路:区间DP

如果((s[i]==’(‘&&s[j]==’)’)||(s[i]==’[‘&&s[j]==’]’)), 很明显这时侯

dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);

其他情况下状态转移方程:dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

char s[110];
int dp[110][110];

int judge(char a,char b)
{
if((a=='('&&b==')')||(a=='['&&b==']'))
return 1;
return 0;
}

int main()
{
while(~scanf("%s",s+1))
{
memset(dp,0,sizeof(dp));
if(!strcmp(s+1,"end"))
break;
int len=strlen(s+1);
int ans=0;
for(int l=1;l<len;++l)
for(int i=1;i+l<=len;++i)
{
int j=i+l;
if(judge(s[i],s[j]))
dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2);
for(int k=i;k<j;++k)
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k+1][j]);
ans=max(ans,dp[i][j]);
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: