您的位置:首页 > 其它

poj 2385 背包问题变形

2017-07-31 23:22 218 查看
题目链接点击打开链接

Apple Catching

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12916 Accepted: 6274
Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However,
she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds. 

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under
only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples). 

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts
at tree 1.
Input

* Line 1: Two space separated integers: T and W 

* Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.
Sample Input
7 2
2
1
1
2
2
1
1

Sample Output
6

Hint

INPUT DETAILS: 

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice. 

OUTPUT DETAILS: 

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.
Source

USACO 2004 November

题目分析:
这道题可以转化为背包问题,效率代表价值,每一分钟不同的树掉下的苹果代表不同的物品,来回走动的次数代表容量
然后我们要考虑边界情况,再者就是考虑在当下这棵树下是否可以得到苹果

#include<iostream>
#include<string.h>
using namespace std;
int t,w,a[1010];
int dp[1010][31];
int main()
{
while(cin>>t>>w)
{
memset(dp,0,sizeof(dp));
for(int i=1;i<=t;i++)
cin>>a[i];
if(a[1]==1)
dp[1][0]=1;//如果一开始第一颗掉苹果
else
dp[1][1]=1;//如果一开始第一颗掉苹果
for(int i=2;i<=t;i++)
{
dp[i][0]=dp[i-1][0]+a[i]%2;//考虑来回次数为零的边界情况,不用考虑时间为0的边界情况,因为无意义
}
for(int i=2;i<=t;i++)
{
for(int j=1;j<=w;j++)
{
dp[i][j]=max(dp[i-1][j-1],dp[i-1][j]);
if(j%2==0&&a[i]==1||j%2==1&&a[i]==2)
dp[i][j]++;//如果在当下这棵树掉苹果,结果+1
}
}
int ans=0;
for(int i=0;i<=w;i++)
ans=max(ans,dp[t][i]);//来回次数最多不一定是最佳情况
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息