您的位置:首页 > 其它

E - How Many Equations Can You Find

2017-07-31 20:18 351 查看
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input

Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output

The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input

123456789 3

21 1

Sample Output

18

1

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
char s[10000];
long long n,ans,len;
void dfs(int sum,int id)
{
if(id==len)
{
if(sum==n)
{
ans++;
}
return ;
}  //判断是否是最后一个数
long long temp=0;
for(int i=id;i<len;i++)
{
temp=temp*10+(s[i]-'0');
dfs(sum+temp,i+1);
if(id!=0)
{
dfs(sum-temp,i+1);
}
}
}

int main()
{
while(scanf("%s%lld",s,&n)!=EOF)
{
ans=0;
len=strlen(s);
dfs(0,0);
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: