您的位置:首页 > 其它

1025. PAT Ranking (25)

2017-07-31 10:58 399 查看


1025. PAT Ranking (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your
job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then
K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4


提交代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
//创建一个结构体方便编写代码
struct Student{
char id[15];//准考证号
int score;//分数
int local_num;//考场号
int local_rank;	//考场内排名
}stu[30010];
//建立排序规则,详情请了解sort函数的用法
bool cmp(Student a,Student b)
{
if(a.score!=b.score)
{
return a.score>b.score;//先按分数从高到低排列
}
else
{
return strcmp(a.id,b.id)<0;//分数相同按准考证号从小到大排序
}
}
int main()
{
int num=0,k,n;//num为学生总数,n为考场数
scanf("%d",&n);//读入有几个考场
for(int i=1;i<=n;i++)
{
scanf("%d",&k);//读入该考场考生人数
for(int j=0;j<k;j++)//读入该考场考生的信息
{
scanf("%s %d",stu[num].id,&stu[num].score);
stu[num].local_num=i;
num++;
}
sort(stu+num-k,stu+num,cmp);//给该考场的考生排序
stu[num-k].local_rank=1;
for(int j=num-k+1;j<num;j++)//给该考场考生定排名
{
if(stu[j].score==stu[j-1].score)
{
stu[j].local_rank=stu[j-1].local_rank;
}
else
{
stu[j].local_rank=j+1-(num-k);
}
}

}
printf("%d\n",num);
sort(stu,stu+num,cmp);
int r=1;
for(int i=0;i<num;i++)//给全部考生定排名
{
if(i>0&&(stu[i].score!=stu[i-1].score))
{
r=i+1;
}
printf("%s %d %d %d\n",stu[i].id,r,stu[i].local_num,stu[i].local_rank);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: