您的位置:首页 > 其它

NYOJ 364 田忌赛马

2017-07-31 10:44 483 查看


田忌赛马

时间限制:3000 ms  |  内存限制:65535 KB
难度:3

描述Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick
4000
. And how do you
think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

输入The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s
horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18


样例输出
200
0
0


如果田忌的坏马比王的坏马快

    赢一局

如果田忌的坏马比王的坏马慢

    输一局

如果田忌的坏马和王的坏马速度一样

    田忌的好马比王的坏马快

            赢一局

    田忌的好马比王的好马慢或相等

              田忌的坏马比王的好马快

                      赢一局

              田忌的好马比王的好马慢

                    输一局

               田忌的坏马和王的好马相等 

                            不加不减

#include<stdio.h>
#include<stdlib.h>
int comp(const void *a,const void *b)
{
return *(int *)b-*(int *)a;
}
int main(void)
{
int num;
while(scanf("%d",&num)!=EOF)
{
int m[1001],n[1001];
for(int i=0;i<num;i++)
scanf("%d",&m[i]);
for(int j=0;j<num;j++)
scanf("%d",&n[j]);
qsort(m,num,sizeof(m[0]),comp);
qsort(n,num,sizeof(n[0]),comp);
int a=0;
int b=0;
int a1=num-1;
int b1=num-1;
int t=0;
while(a<=a1)
{
if(m[a1]>n[b1])
{
a1--;
b1--;
t++;
}
else if(m[a1]<n[b1])
{
a1--;
b++;
t--;
}
else if(m[a]>n[b])
{
a++;
b++;
t++;
}
else
{
if(m[a1]>n[b])
{
b++;
a1--;
t++;
}
else if(m[a1]<n[b])
{
b++;
a1--;
t--;
}
else
{
b++;
a1--;
}
}
}
printf("%d\n",200*t);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: