您的位置:首页 > 其它

2014广州亚洲现场赛/HDU 5131 Song Jiang's rank list(水题)

2017-07-31 08:45 549 查看


Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)

Total Submission(s): 1746    Accepted Submission(s): 983


Problem Description

《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including
scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two
outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.

 

Input

There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique. 

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name. 

The input ends with n = 0

 

Output

For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed. 

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws
who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed
that each query has an answer for it.

 

Sample Input

5
WuSong 12
LuZhishen 12
SongJiang 13
LuJunyi 1
HuaRong 15
5
WuSong
LuJunyi
LuZhishen
HuaRong
SongJiang
0

 

Sample Output

HuaRong 15
SongJiang 13
LuZhishen 12
WuSong 12
LuJunyi 1
3 2
5
3
1
2

 

Source

2014ACM/ICPC亚洲区广州站-重现赛(感谢华工和北大)

 

题意:给定N个人的姓名和他的杀敌数,然后按照杀敌数从大到小排序,数值相同的,名字字典序小的排在前。
然后先把排序的结果输出。
再来M个询问,每个询问是查询某个人的排名,排名由两部分构成。第一部分是求出杀敌数比他大的人数+1,第二部分是跟他杀敌数相同但排名比他靠前的人数+1,如果第二部分的答案是1,则不用输出。
N和M都不过200,于是水题一枚,对于询问直接暴力扫就行了。
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <string.h>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#include <stdlib.h>
#define lowbit(x) (x&-x)
#define e exp(1.0)
//ios::sync_with_stdio(false);
// auto start = clock();
// cout << (clock() - start) / (double)CLOCKS_PER_SEC;
typedef long long ll;
typedef long long LL;
using namespace std;
struct node
{
string name;
int num;
int ranks;
}a[305];
int pos[305];
int cmp(const node &a,const node &b)
{
if(a.num==b.num)return a.name<b.name;
return a.num>b.num;
}
int main()
{
int n;
while(cin>>n && n)
{
memset(pos,0,sizeof(pos));
for(int i=0;i<n;i++)
{
cin>>a[i].name>>a[i].num;
pos[a[i].num]++;
}
sort(a,a+n,cmp);
for(int i=0;i<n;i++)
cout<<a[i].name<<' '<<a[i].num<<endl;
int ans=0;
int k;
cin>>k;
string s;
while(k--)
{
ans=0;
cin>>s;
int number;
for(int i=0;i<n;i++)
if(a[i].name==s)
number=a[i].num;
for(int i=0;i<n;i++)
{
if(a[i].num>number)
ans++;
}
cout<<ans+1;
ans=0;
for(int i=0;i<n;i++)
{
if(a[i].name<s && a[i].num==number)
ans++;
}
if(ans)
cout<<" "<<ans+1;
cout<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  水题