您的位置:首页 > 其它

POJ-2891-Strange Way to Express Integers(解线性同余方程)

2017-07-30 22:07 405 查看
Strange Way to Express Integers

Time Limit: 1000MS Memory Limit: 131072K

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1, a2, …, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1, a2, …, ak are properly chosen, m can be determined, then the pairs (ai, ri) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

Line 1: Contains the integer k.

Lines 2 ~ k + 1: Each contains a pair of integers ai, ri (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2

8 7

11 9

Sample Output

31

这是线性同余方程的模板题

#include <cstdio>
typedef long long ll;
void gcd(ll a,ll b,ll &q,ll &x,ll &y)
{
if(b==0)
{
x=1;
y=0;
q=a;
}
else
{
gcd(b,a%b,q,x,y);
int tem=x;
x=y;
y=tem-a/b*y;
}
}
int main()
{
int k;
while(~scanf("%d",&k))
{
ll a1,r1,a2,r2,a,b,c;
ll q,x,y;
bool flag=1;
scanf("%lld%lld",&a1,&r1);
for(int i = 1;i < k;i ++)
{
scanf("%lld%lld",&a2,&r2);
a=a1;b=a2;c=r2-r1;
gcd(a,b,q,x,y);
if(c%q!=0)
flag=0;
ll tem=b/q;
x=(x*(c/q)%tem+tem)%tem;
r1=a1*x+r1;
a1=a1*(a2/q);
}
if(flag)
printf("%lld\n",r1);
else
printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: