您的位置:首页 > 其它

POJ2407 Relatives(欧拉函数)

2017-07-30 21:06 387 查看
Link: 点击打开链接

Relatives

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14839 Accepted: 7456
Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output

For each test case there should be single line of output answering the question posed above.
Sample Input
7
12
0

Sample Output
6
4


思路:

欧拉函数

Code:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<cstring>
#include<stack>
#include<queue>
using namespace std;
int main()
{
int n;
while(~scanf("%d",&n)&&n)
{
int ans=1,i;
for(i=2;i*i<=n;i++)
{
if(n%i==0)
{
n/=i;
ans*=i-1;
while(n%i==0)
{
n/=i;
ans*=i;
}
}
}
if(n>1)
ans*=n-1;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: