您的位置:首页 > 其它

Atcoder AtCoder Regular Contest 079 E - Decrease (Judge ver.)

2017-07-30 19:51 477 查看

E - Decrease (Judge ver.)

Time limit : 2sec / Memory limit : 256MB

Score : 600 points

Problem Statement

We have a sequence of length N consisting of non-negative integers. Consider performing the following operation on this sequence until the largest element in this sequence becomes N−1 or smaller. (The operation is the same as the one in Problem D.)

Determine the largest element in the sequence (if there is more than one, choose one). Decrease the value of this element by N, and increase each of the other elements by 1.

It can be proved that the largest element in the sequence becomes N−1 or smaller after a finite number of operations.

You are given the sequence ai. Find the number of times we will perform the above operation.

Constraints

2≤N≤50
0≤ai≤1016+1000

Input

Input is given from Standard Input in the following format:

N
a1 a2 ... aN


Output

Print the number of times the operation will be performed.

Sample Input 1

Copy
4
3 3 3 3


Sample Output 1

Copy
0


Sample Input 2

Copy
3
1 0 3


Sample Output 2

Copy
1


Sample Input 3

Copy
2
2 2


Sample Output 3

Copy
2


Sample Input 4

Copy
7
27 0 0 0 0 0 0


Sample Output 4

Copy
3


Sample Input 5

Copy
101000 193 256 777 0 1 1192 1234567891011 48 425


Sample Output 5

Copy
1234567894848

模拟一下就可以了


#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <cstdlib>
#include <iomanip>
#include <cmath>
#include <ctime>
#include <map>
#include <set>
using namespace std;
#define lowbit(x) (x&(-x))
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
#define MAX 100000000000000000#define MOD 1000000007
#define pi acos(-1.0)
#define ei exp(1)
#define PI 3.141592653589793238462#define ios() ios::sync_with_stdio(false)
#define INF 0x3f3f3f3f3f
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
ll n,k,x,m;
priority_queue<ll>q;
int main()
{
ios();
scanf("%lld",&n);
for(int i=1;i<=n;i++)
{
scanf("%lld",&x);
q.push(x);
}
k=0;
while(q.top()+k>=n)
{
ll ans=q.top()+k;
q.pop();
m=ans/n;
ans-=m*n;
k+=m;
q.push(ans-k);
}
printf("%lld\n",k);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: