您的位置:首页 > 其它

POJ1459 Power Network(最大流)

2017-07-30 15:48 351 查看
Power Network

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 28597 Accepted: 14818
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount
0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power
transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of
Con. 



An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y.
The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets
(u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set
ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can
occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input
2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4

Sample Output
15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second
data set encodes the network from figure 1.
Source

Southeastern Europe 2003

思路:本题是多源,多汇的网络流问题,可以将其转化为单源单汇问题;

在原图中增加一个新“源点”s和新的“汇点“”t,对于每个发电站,从源点s引一条容量为Pmax的弧;对于每个消费者,引一条容量为Cmax的弧到汇点t;

然后求此网络的最大网络流即可,最大网络流模板点击打开链接

代码:(POJ评测系统问题会显示编译错误)

#include <stdio.h>
#include <algorithm>
#include <vector>
#include <string.h>
using namespace std;
#define max_v 110
#define INF 10000

int n,u,v,np,nc,z,s,t,m,c;

//用于表示边的结构体(终点,容量,反向边)
struct edge
{
int to,cap,rev;
};

vector<edge> G[max_v];//图的邻接表表示
bool used[max_v];//DFS中用到的访问标记

//向图中增加一条从s到t容量为cap的边
void add_edge(int from,int to,int cap)
{
G[from].push_back((edge){to,cap,G[to].size()});
G[to].push_back((edge){from,0,G[from].size()-1});
}

//通过DFS寻找增广路
int dfs(int v,int t,int f)
{
if(v==t)      return f;
used[v]=true;
for(int i=0;i<G[v].size();i++)
{
edge &e=G[v][i];
if(!used[e.to]&&e.cap>0)
{
int d=dfs(e.to,t,min(f,e.cap));
if(d>0)
{
e.cap-=d;
G[e.to][e.rev].cap+=d;
return d;
}
}
}
return 0;
}

//求解从s到t的最大流
int max_flow(int s,int t)
{
int flow=0;
for(;;)
{
memset(used,0,sizeof(used));
int f=dfs(s,t,INF);
if(f==0)     return flow;
flow+=f;
}
}

int main()
{
scanf("%d%d%d%d",&n,&np,&nc,&m);
s=n;t=n+1;
for(int i=0;i<m;i++)
{
while((c=getchar())!='(');
scanf("%d%c%d%c%d",&u,&c,&v,&c,&z);
add_edge(u,v,z);
}
for(int i=0;i<np;i++)
{
while((c=getchar())!='(');
scanf("%d%c%d",&u,&c,&z);
add_edge(s,u,z);
}
for(int i=0;i<nc;i++)
{
while((c=getchar())!='(');
scanf("%d%c%d",&u,&c,&z);
add_edge(u,t,z);
}
printf("%d\n",max_flow(s,t));
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: