您的位置:首页 > 其它

The kth great number(优先队列)

2017-07-30 14:27 246 查看


The kth great number

 

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is
feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao
Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3

I 1

I 2

I 3

Q

I 5

Q

I 4

Q

Sample Output

1

2

3

此题要用STL解  优先队列priority_queue  (大顶堆)  从小到大排序,当存入数字多于K个时把小的那个数pop掉,最后输出第一个数就行了

AC代码:

#include<iostream>
#include<algorithm>
#include<set>
#include<cstdio>
#include<queue>
using namespace std;
int main()
{
int n,m;
char ch;
while(scanf("%d%d",&n,&m)!=EOF)
{
int x;
priority_queue<int,vector<int>,greater<int> > q;
while(n--)
{
cin>>ch;
if(ch=='I'){
cin>>x;
q.push(x);
if(q.size()>m)
q.pop();
}
else{
cout<<q.top()<<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: