您的位置:首页 > Web前端

Fence Repair POJ - 3253

2017-07-29 20:50 549 查看
https://cn.vjudge.net/problem/15032/origin

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the Nplanks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input
Line 1: One integer N, the number of planks 

Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input
3
8
5
8


Sample Output
34


Hint
He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题意:将一块很长的木板切割成N块。准备切成的木板的长度

为L1,L2,L3......Ln块。未切割前的木ban板的长度恰好为切

割后的木板长度的总和。每次切断木板时,需要的开销为这块

木板的长度。例如长度为21 的木板要切割成5.8.8的三块木板。

长21的木板切成为13和8,开销为21,再将长度为13的木板切成

长度为5和8的木板,开销为13,于是总开销为34,请求出按照

目标要求将木板切割完最小的开销是多少?

思路:我们可以反其到而行之,我们只需从木板的集合里,取

出最短的两块,并且把长度之和加入集合中即可,最后对列里

面只含有一块即可,因此使用优先队列可以高效的实现。

#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;
typedef long long ll;

int N,L[20010];
void solve()
{
ll ans=0;
priority_queue<int ,vector<int>, greater<int> > que;
for(int i=0; i<N; i++)
que.push(L[i]);
while(que.size()>1)
{
int t1,t2;
t1=que.top();
que.pop();
t2=que.top();
que.pop();
int sum=t1+t2;
ans+=sum;
que.push(sum);
}
printf("%lld\n",ans);
}
int main()
{
while(~scanf("%d",&N))
{
for(int i=0; i<N; i++)
scanf("%d",&L[i]);
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: