您的位置:首页 > 其它

hdu1907

2017-07-29 11:12 295 查看


John

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 4899    Accepted Submission(s): 2834


Problem Description

Little John is playing very funny game with his younger brother. There is one big box filled with M&Ms of different colors. At first John has to eat several M&Ms of the same color. Then his opponent has to make a turn. And so on. Please note that each player
has to eat at least one M&M during his turn. If John (or his brother) will eat the last M&M from the box he will be considered as a looser and he will have to buy a new candy box.

Both of players are using optimal game strategy. John starts first always. You will be given information about M&Ms and your task is to determine a winner of such a beautiful game.

 

Input

The first line of input will contain a single integer T – the number of test cases. Next T pairs of lines will describe tests in a following format. The first line of each test will contain an integer N – the amount of different M&M colors in a box. Next line
will contain N integers Ai, separated by spaces – amount of M&Ms of i-th color.

Constraints:

1 <= T <= 474,

1 <= N <= 47,

1 <= Ai <= 4747

 

Output

Output T lines each of them containing information about game winner. Print “John” if John will win the game or “Brother” in other case.

 

Sample Input

2
3
3 5 1
1
1

 

Sample Output

John
Brother
思路:首先看数据是否全为1,如果是的话,按数目的奇偶性判断,如果不是全为1,那就将全部数据异或起来,看是否为0.
代码:
#include <map>
#include <set>
#include <queue>
#include <vector>
#include <stack>
#include <cmath>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
#define long long int ll
#define ma(a) memset(a,0,sizeof(a))
int SG[10005],f[105];
bool S[10005];
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int m;
scanf("%d",&m);
int i;
int sum=0;
int a[105];
int k=0;
for(i=0;i<m;i++)
{
scanf("%d",&a[i]);
if(a[i]==1)k++;
}
sort(a,a+m);
for(i=0;i<m;i++)
{
sum^=a[i];
}
if(k==m)
{
if(m%2==0)cout<<"John"<<endl;
else cout<<"Brother"<<endl;
continue;
}
if(sum==0)cout<<"Brother"<<endl;
else cout<<"John"<<endl;
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: